Announcement

Collapse
No announcement yet.

Fritz salt

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fritz salt

    Has anyone had any issues with fritz salt? I recently had some issues and have seen a few others go through the same thing. I mixed 20g for a qt tank to 1.026. All seemed well but I decided to check parameters. I was shocked to find alk at 5.5! After some research ive found a few other cases of fritz users having alk drop from 8.5 to 5-6 in 24hrs or less. Does anyone have any information on what happened? It wasnt precipitation. Tank was spotless with 0 signs of any fallout

  • #2
    I've only ever used kent, but they typically have lower alk at around 8 on average from what I've heard. Possibly a bad batch
    -Travis-

    Comment


    • #3
      Its just odd ive never had salt mix at 8.5 then drop only a few hours later. Im comparing batch #s with a few other people who had this same issue

      Comment


      • #4
        precipitation?
        -Travis-

        Comment


        • #5
          How long are you waiting to check the batch after its made

          Comment


          • #6
            I have run through about 600 gallons of Fritz on my tank. Seems pretty consistent across the board. So far been a good salt. Mixes up clear after about 15 mins and is ready to go in. No crap in mixing buckets either.
            ==> New 210 Miracles Starphire Build in Progress!

            Comment


            • #7
              I had a similar experience with reef crystals, every bucket was wildly different in parameters from the last so i finally switched to red sea and havent had any inconsistencies with them yet. I always test the source water from the first mix of a new bucket.

              Comment


              • #8
                No precipitation. Mixed water until it was clear and used it to fill up my newest QT/frag tank. Checked it approximately 2 hours after filling the tank. Checked with hanna checker and salifert. I believe I have figured out the inconsistency issues. I think the different components are settling out during shipping and I need to mix the salt better before using. Imy newest box had calcium mixing up above 500 so I think this is the problem. Ive never had problems with fritz until these last 2 boxes. I will keep this updated as I know many of us have switched to fritz. Its most likely my error but if there is an issue I want to communicate batch #s asap

                Comment

                Working...
                X